Member Login

Freestyle Joomla Forums

Includes: Code

Member Login   Register

Please login or register to post on the forum

Forum Index    Board Index    Last Post   

Chris

Chris

09 January 2014, 07:29

http error 500

Hi, installed the component all seemed ok no error messages.

then get the following error when trying to select it:

The website encountered an error while retrieving http://sitename/administrator/index.php?option=com_fsj_codeincl. It may be down for maintenance or configured incorrectly.
Here are some suggestions:


HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.
Link showing problem ??
Freestyle Version latest from website
Pro/Lite Lite
Adam Clarke

Adam Clarke

09 January 2014, 10:51

Re: http error 500

Hello

I have been unable to reproduce this error.

Can you provide me with a few more details please, including which link you clicked on to produce the error (where in the menus and what url).

Also, can you include a screenshot of the error.

If you goto Global Configuration, in the System tab, enable Debug System, and in the Server tab set error reporting to Maximum. Visit the page you have having issues and let me know what errors are displayed please.

Thanks

Adam Clarke
Freestyle Joomla
Chris

Chris

09 January 2014, 12:59

Re: Audit Message

Hi Adam,

Thanks for the quick response, sorry I wasn't about to deal with it earlier (meetings)

It happens when I select the either of the freestyle includes components (code lite and includes) from the components-->Freestyle Joomla

Ok so I've turned on error reporting and get the following error:

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/instant/instantcounselling.org/libraries/fsj_core/admin/toolbars.php on line 31
Adam Clarke

Adam Clarke

09 January 2014, 13:16

Re: http error 500

Hello

No problems.

I think the error may be related to using PHP 5.2 on your site. Can you check if this is the case please?

All our components require PHP 5.3 or above to function.

Thakns

Adam Clarke
Freestyle Joomla
Chris

Chris

09 January 2014, 14:34

Re: Audit Message

Yep that'll be why then, it's been a stumbling block a few times already, any way to work around it?
Chris

Chris

09 January 2014, 14:35

Re: Audit Message

Just a quick fyi.  Your testimonials component works fine with 5.2.
Adam Clarke

Adam Clarke

09 January 2014, 14:41

Re: http error 500

Hello

Im not actually sure how much of the Includes: Code code requires php 5.3.

It may be that its just a few small parts so it could be worked around.

To get rid of the error you are getting edit the file libraries/fsj_core/admin/toolbars.php and change line 31 to:

JSubMenuHelper::addEntry(

If you are not using the default admin template this may cause issues though.

Let me know how you get on with this.

Thanks

Adam Clarke
Freestyle Joomla
Chris

Chris

09 January 2014, 16:21

Re: Audit Message

Thanks Adam, will give it a try.

I'm using the default admin side of things.  Let you know in 10 mins
Chris

Chris

09 January 2014, 16:37

Re: Audit Message

Thanks Adam, had to replace a few more references further down the file, but works great.


Thanks again.
Adam Clarke

Adam Clarke

09 January 2014, 16:58

Re: http error 500

Hello

I have now closed this ticket. If you have any further issues then please let me know, I will be happy to help.

Thanks

Adam Clarke
Freestyle Joomla
wanda0123

wanda0123

31 July 2017, 10:33

Re: Audit Message

I am a new member. What's new? Please introduce me.









Online

Vote For Us!

Please vote for our software or write a review of one of our products on the Joomla! Extensions Directory