Member Login

Announcements - Support for Joomla 1.6 and 1.7

Administrator @ 10 April 2012

We have re-added support for Joomla 1.6 and 1.7 due to popular demand. Support for these versions of Joomla will remain for the forseeable future.


Freestyle Joomla


Vote For Us!

Please vote for our software or write a review of one of our products on the Joomla! Extensions Directory